[Solved] The trouble with the FTDI board and the Atmega328-PU

It all started when I wanted to get away from using Ardiunos so I decided to use a Atmega328 and a FTDI board. The first chip I got was a Atmega328P-PU which took a bit of wrestling to get the arduino boot loader installed and working with the IDE, but after that it acted just like a regular arduino.

On my next project after that I decide to try to order from a different seller on eBay and ended up getting a Atmega328-PU. This also took a bit of hoop jumping to get the Arduino boot loader installed but no where as bad as the Atmega328P-PU. My problem is that I can plug the FTDI board connected to the Atmega328 into the computer, then start-up the arduino IDE, load up the sketch, then send the sketch over to the Atmega328-PU. but if I then load up another sketch and try and upload that to the Atmega328-PU it gives the out of sync error.

Selection_002

 

Here is my bread board set up I was using to test out my project

pumpkin_led_bb

I didn’t see the problem right away, at first I thought it was the cap I was using since it was using a polarized capacitor instead of a 104 disk cap so I switched. I didn’t see any change in the behaviour, I looked at my ardiuno which came with a Atmega328-PU chip in it. I took the chip out of the arduino and tried it in the bread board I had been using, This acted just the same as the other one had. I’m using version 1:1.0.5+dfsg 2-2 on Ubuntu 14.04. It could be one of 3 things.

  1. The version of the IDE im using.
  2. The FTDI board im using since its different but looks the same as the one I used with the Atmega328P-PU
  3. That it’s just the way the Atmega328-PU works with the software and the FTDI board.

After getting it so I could upload a sketch to the board like a stated above I decided to just populate the PCB I had designed for this project and see if it would work any better. after populating the PCB and checking that everything worked ok I try to upload a sketch to it, To my horror I couldn’t even upload a sketch to it at all, all I was getting was an out of sync error message.

IMG_20141024_093335

After picking myself off of the ground I started having a look round on google to see if anyone else was having similar problems to me with the same set up. I seen that someone suggested that I try a different USB cable since the one was using was one of these really cheap chinese ones with little to no shielding or ferrite core. I pulled out my PS3 charging cable that had a ferrite core on the cable and tried to upload a sketch, to my astonishment it worked. I hurriedly tried to upload it again just to make sure it wasnt a fluke this is when my heart sunk as it failed. I found that if you had a “fresh” cable (one that havent been plugged in before) that it would let me upload a sketch once to the board. This makes me think it would be a capacitor problem.

I have ordered a Atmega328P-PU to try that in the board and so i can play around with both chips on a bread board to see if different capacitor size can sort out the problem.

So my Atmega328P-PU came in the post, I set it up in a bread board the usual way that I do , shown below

bare_bones_arduino_right_way_bb

 

but For some reason when I wired up my schematic I always wire it up the way ive shown below

bare_bones_arduino_wrong_way_bb

 

This is what was giving me the problem where when I first connected it to my computer, I could upload one sketch but when I try to upload a second sketch I would give out of sync error. This happens when ever I connect to my computer. I found if I add a 10k resistor between the pin 1 and VCC I would work fine.

There is no way to fix my PCB but at least I’ve found away to ensure future projects will work. What really puzzles me is that I connected up my VCC and GND to pin 7 and pin 8 respectively on my #atmega_screen but I was still able to upload sketches using a FTDI board. The set up is shown below

atmega_screen_bb

I would love to hear off anyone that’s had this problem in the past or noticed anything similar to this situation

EDIT

After lots of digging around on forums I tracked down my problem. I needed a 1000 ohm resistor going from pin 1 to VCC. This would fix my issues with uploading sketches to the board

Advertisements

2 responses to “[Solved] The trouble with the FTDI board and the Atmega328-PU

    • Hi, that is a valid comment. Not sure this is the correct answer but the reason I didn’t connect it was that it already had power and ground from pins 7 and 8 so I didn’t think it needed pins 20 and 22 also connected. Like I said I might be wrong

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s